rapidminer launching issue

rimrim Member Posts: 3 Learner I
Hello everyone, i just started to study bigdata and we had to install rapidminer, but everytime i try to launch it after i install it it gives me this error. can anyone help me to solve this problem. thank you!

Best Answers

  • MartinLiebigMartinLiebig Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,505 RM Data Scientist
    Solution Accepted
    Hi,
    thats interesting.. @jwpfau do you know this?

    BR,
    Martin
    - Sr. Director Data Solutions, Altair RapidMiner -
    Dortmund, Germany
  • rjones13rjones13 Member Posts: 153 Unicorn
    Solution Accepted
    Hi,

    I'm just wondering which version you're installing and for which operating system? Is this v10.2 for Windows 64bit?

    Best,

    Roland
  • jwpfaujwpfau Employee, Member Posts: 275 RM Engineering
    edited November 2023 Solution Accepted
    Hi @rim,

    There is a known issue with non-ascii usernames in 10.2 / 10.3.

    As a workaround you could point your .RapidMiner folder to another directory by adding i.e.
    -Drapidminer.user-home=C:\.RapidMiner
    to line 158 of the C:\Program Files\RapidMiner\RapidMiner Studio\RapidMiner Studio.bat 

    "%JAVA%" %JVM_OPTIONS% -cp "%RAPIDMINER_HOME%"\lib\* com.rapidminer.launcher.GUILauncher %CMD_LINE_ARGS%
    would change to:
    "%JAVA%" %JVM_OPTIONS% -Drapidminer.user-home=C:\.RapidMiner -cp "%RAPIDMINER_HOME%"\lib\* com.rapidminer.launcher.GUILauncher %CMD_LINE_ARGS%

    Afterwards you would need to start RapidMiner Studio via the .bat file until this is fixed.

    Greetings,
    Jonas

Answers

  • rimrim Member Posts: 3 Learner I
    rjones13 , thank you for replying. yes i downloded the latest version which is 10.2 for windows 10 64bits.
  • rimrim Member Posts: 3 Learner I
    thank you so much @jwpfau it worked. after i did what you say it only asked me to add home path then when i did it worked. you saved me i was going crazy trying everything.
  • krisz86krisz86 Member Posts: 4 Learner I
    Hi @jwpfau

    I had the same problem. I did what you said here, although I still not able to open it. Actually when I did what you said here I had to disable the firewall on Windows for some reason because it detected something.

    Although it is still not working,

    Please help me ASAP, I need to deliver an unuveirsty assignment with a close deadline

    Thanks,
    Krisztian
  • jwpfaujwpfau Employee, Member Posts: 275 RM Engineering
    Hi Krisztián,

    can you share a screenshot of the error that you get when starting with the .bat file?
    Best would be if you could start a new thread in the community.

    Greetings,
    Jonas
Sign In or Register to comment.