Does anybody have a copy of rmx_text-ANY-9.4.0.jar to share?

LeoTGDLeoTGD Member Posts: 2 Newbie
Hello Community,

I'm doing a training that requires me to use RM 9.10 and following extensions: Text Processing, Operator Toolbox and Recommender Extension.

My initial problem with extensions is that for some reason I can't connect to the Market Place to automatically install them - and I couldn't find any solution for this problem. So my plan B was to search if I could install those extensions in a different way and after looking some helpful comments here I learned it's possible, I just need to download the .jar files and place them on \.RapidMiner\extensions.

The problem is the .jar file for Text Processing we have available is rmx_text-ANY-10.0.0 which will not work with Operator Toolbox. Well digging a bit more on the internet I found and downloaded rmx_text-ANY-9.3.1 hoping that would make the trick....unfortunately not. Apparently the version I need is rmx_text-ANY-9.4.0 which I can't find anywhere.

This community is amazing and I hope I can get some help here to either fix my connection problem to the Market Place (I'm afraid it's related to the firewall on my company's laptop) or with the correct .jar file.

Thanks in advance,
Leo 

Best Answers

  • MartinLiebigMartinLiebig Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,483 RM Data Scientist
    edited January 29 Solution Accepted
    Hi there,

    are you sure 10.0 text doesnt work with toolbox? Even though the dependency is set to 9.3.1 I always thought its upwards compatible.

    Anyway you can just change the marketplace URL to the respective version. So https://marketplace.rapidminer.com/UpdateServer/faces/download.xhtml?productId=rmx_text&platform=ANY&version=9.3.1 gives you 9.3.1.

    Best,
    Martin

    - Sr. Director Data Solutions, Altair RapidMiner -
    Dortmund, Germany
    LeoTGDBalazsBarany
  • MartinLiebigMartinLiebig Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,483 RM Data Scientist
    Solution Accepted
    Hi there,

    there was a change from java 7 to a newer java from RM v9 to v10. So that might be the cause that you cant use newer versions.

    Best,
    Martin
    - Sr. Director Data Solutions, Altair RapidMiner -
    Dortmund, Germany
    LeoTGDBalazsBarany

Answers

  • LeoTGDLeoTGD Member Posts: 2 Newbie
    Martin,

    Thank you very much!!! :)

    With that link you just sent me, I was able to download a good .jar file for Text Processing that worked with Operator Toolbox. Now everything is working so it looks like the problem was that the dependency is not really upwards compatible.

    Just to summarize in case it helps other users that have to install & use RapidMiner 9.10 and can't download extensions directly from the Market Place, those are the following .jar files I had to download and install manually (super easy process): 
    • Text Processing: rmx_text-ANY-9.3.1.jar
    • Operator Toolbox: rmx_operator_toolbox-ANY-2.17.0.jar
    • Recommender Extension: rmx_irbrecommender-ANY-5.1.2.jar
    Thanks again,
    Leo
Sign In or Register to comment.