The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

Limit of import file RM?

rocky888rocky888 Member Posts: 3 Contributor I
edited November 2018 in Help
Hello

I know this may be a very basic question but what i am trying to do is import my .csv file into repository created in RM.

The file is 80MB of data, when importing the progress on impending tasks is not moving too far. The dialog appears with importing tasks with 4bars but no progress being made.

Is there a limit on the import file in RM?

Answers

  • Options
    landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Hi,
    no there should be no such limit. We have recently found a problem with nominal values being larger than 64k, because one of the java methods throws an undocumented exception then. Do you have very large nominal values like websites or hole books?
    If that's not the case, it is confidential data? Otherwise I would appreciate very much, if you could send it to me, so that I can check what's going wrong.

    In the meanwhile there's a different way to import the data into your repository. Use the read csv operator to load the csv file directly in a process and then write the results back using a storer. You might adapt roles and types before using the standard operators for that purpose.

    Greetings,
      Sebastian
  • Options
    MartinKochMartinKoch Member Posts: 16 Contributor II
    Hi rocky888,

    I have similiar problems and stumbled upon your post right now.

    My thread is:
    http://rapid-i.com/rapidforum/index.php/topic,1924.0.html

    Maybe it helps a little. In short a solution could be to import your csv file with the "Import CSV" operator but without "parse numbers" checked. After that you use the "Guess types" operator or adjust the types manually or both.

    Greetings
    Martin
Sign In or Register to comment.