The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

Importing data into repository

maurermaurer Member Posts: 7 Contributor II
edited November 2018 in Help
Hi,
is there any way to import multiple files into repository at once? I have about 100 csv files in a directory which I would like to import and it's quite tedious to do it manually.

cheers,
maurer

Answers

  • Options
    haddockhaddock Member Posts: 849 Maven
    Greetings!

    Motaz had a similar question, so this http://rapid-i.com/rapidforum/index.php/topic,1731.msg6958.html#msg6958 might be of interest.
  • Options
    maurermaurer Member Posts: 7 Contributor II
    haddock wrote:

    Greetings!

    Motaz had a similar question, so this http://rapid-i.com/rapidforum/index.php/topic,1731.msg6958.html#msg6958 might be of interest.
    Thank you for your helpful answer, but I still have one problem.
    As I import data from csv manually RM labels some columns with 'integer' label which is not true because they have floating point values. If I automate the loading procedure all the data in those columns is loaded as 'integer' and I lose plenty of useful information. What can I do to prevent such behavior?
  • Options
    haddockhaddock Member Posts: 849 Maven
    Hi there,

    Without seeing the data I can't be too helpful; however, the CSV reader is pretty reliable, so the answer probably lurks in the data. For instance, if your column separator parameter is the default setting then a misplaced space can screw things up, and so on.

    Good luck!

  • Options
    maurermaurer Member Posts: 7 Contributor II
    haddock wrote:

    Hi there,

    Without seeing the data I can't be too helpful; however, the CSV reader is pretty reliable, so the answer probably lurks in the data. For instance, if your column separator parameter is the default setting then a misplaced space can screw things up, and so on.

    Good luck!


    Hi,
    using ReadCSV operator "solves" the problem. It works but still there's a funny thing about data. The column is recognized as integer but floating point values are stored. As long as it works it's however no problem to me.
Sign In or Register to comment.