🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

"Connection to a Oracle database"

Legacy UserLegacy User Member Posts: 0 Newbie
edited May 2019 in Help
Hi all,

I have a problem at connecting to a Oracle database. I use an ODBC driver in order to connect. The wizard approves in the meantime that the connection has been done successfully. That was not this way all the time.

But now I have the problem that Rapidminer shuts completely down when I select the tables and attribute sin the wizard or sometiems even when I just start the wizard.

Is there a better way than using an ODBC connection?

When I use the Oracle driver (e.g. jdbc:oracle:thin:@lispsn4.com:1521:ifcnsl01) I get the following error message. This says that no suitable driver has been found. How can I install the proper drivers? Where is my mistake?

Does any one of you have expereinces with oracle databsse? Are there any example (files) I can have a look at?

Thank you in advance!

Best regards,
Stefan
Tagged:

Answers

  • IngoRMIngoRM Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Community Manager, RMResearcher, Member, University Professor Posts: 1,751  RM Founder
    Hello Stefan,

    I have no experience with accessing Oracle through a ODBC driver but I can assure you that the connection will work through a JDBC driver - at least in principle  ;)

    First thing is to select the correct driver. This driver usually is the one delivered with your Oracle distribution, but you can also download the correct driver at

    http://www.oracle.com/technology/software/tech/java/sqlj_jdbc/index.html

    After selecting the correct driver you have to put it into the "jdbc"-subdirectory of RapidMiner. Restart RapidMiner and select the item "Show database drivers..." from the "Tools" menu. Is your driver found and a green tick is shown? Then everything should work from the technological point of view.

    Of course you have to specify the correct database URL. The message "no suitable driver found" unfortunately is always thrown if anything does not work with the URL - even _if_ the correct driver is there.

    Hope that helps,
    Ingo
  • amithatobviousamithatobvious Member Posts: 6 Contributor II
    This was the closest thread to what I was working with, but I don't think my problem is the same.

    When I use the GUI to import data from MySQL (DatabaseExampleSource), it works fine and imports all my data.
    But, when I use Rm as a library, it gives me a 'no suitable driver found' error.

    The process xml is the exactly the same, and I'm fairly certain I'm doing enough to initialize the right drivers, so I'm kind of at a loss.

    Is there something you have to do different in java to make the URLs work? I've made stupid mistakes before, so I guess this could be another one of those times...

    Thanks in advance, and I'll re-post if I figure it out before then.

    -Eric
  • IngoRMIngoRM Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Community Manager, RMResearcher, Member, University Professor Posts: 1,751  RM Founder
    Hi,

    just put your jdbc driver to the classpath of your Java project and set the property "rapidminer.init.jdbc.classpath" to "true", i.e. you will have to invoke

    System.setProperty("rapidminer.init.jdbc.classpath", "true");
    before you call the init() method.

    The latest CVS version also contains a new init method where you can specify where the JDBC drivers are located (and also a corresponding property).

    Cheers,
    Ingo

  • Legacy UserLegacy User Member Posts: 0 Newbie
    Hi,

    I've the same problem as the first writer (perhaps you can help me). I'm trying to connect to an Oracle database as well. I copied the  file "classes12.jar" (downloaded from the stated website) and pasted it into the jdbc subfolder of rapidminer.

    Unfortunatelly nothing happens. The driver traffic light does not become green. :-(

    What else needs to be done? I tried rapidminer with excel, which works quite well. The results are great.

    Maybe I downloaded the wrong driver? "classes12.jar" does not sound correct.

    Thanks for your advice!
  • TobiasMalbrechtTobiasMalbrecht Moderator, Employee, Member Posts: 291  RM Product Management
    Hi Newbie,

    generally it should be sufficient to copy the appropriate driver (the .jar file) into the jdbc subfolder of RapidMiner and nothing else needs to be done. I just browsed the oracle web site. Although I of course do not know what Oracle version you have, the file "classes12.jar" seems to work (only?) with JDK1.2/1.3. There are however drivers for newer JDK versions (e.g. "ojdbc14.jar"). I would try to download and use these ...

    Regards,
    Tobias
  • jhornychjhornych Member Posts: 1 Contributor I
    Hi,

    I am even wondering how you were able to put in there the SID name as the connection manager is not having any field for it.

    This should be the expected structure, but I was not able to generate anything close to it jdbc:oracle:thin:[user/password]@[host][:port]:SID

    I would prefere to use tnsnames anyway.

    Thank you
    Jan
  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531   Unicorn
    Hi,
    have you already tried to enter the SID in the port field with : as a separator? Seems to work on my side...

    Greetings,
      Sebastian
  • peramankiperamanki Member Posts: 1 Contributor I
    Hi,
    Tried the following towards connecting to Oracle Database (11g R2). But driver indicator in Rapid Miner is still red. Appreciate help.

    1)Copied OJDBC6.jar file to JDBC sub folder under RapidMiner
    2)Copied OJDBC5.jar file to JDBC sub folder under RapidMiner
    3)Copied OJDBC14.jar file to JDBC sub folder under RapidMiner

    Thanks
  • Nils_WoehlerNils_Woehler Member Posts: 463  Maven
    Hi,

    Oracle has changed the Drive package name and thus our current default entry will not work anymore.
    To get Oracle working create a new database driver entry with following attributes:
    Name: Oracle_new

    Port: 1521
    Schema separator: /
    Jar file: Point to your \ojdbc6_g.jar
    Driver class: oracle.jdbc.OracleDriver

    Best,
    Nils
Sign In or Register to comment.