"Fail to initialize RM in Java"

wendywendy Member Posts: 7 Contributor II
edited June 2019 in Help

I just migrated to RM 5 and I want to use some RM operators in my Java application. But immediately I have this problem in initializing the RM. Please take a look at my code:

System.setProperty("rapidminer.home", "C:\\Program Files\\Rapid-I\\RapidMiner5");
I guess the code should be as simple as above.. right? But I received this error message:

2010-07-13 12:08:21 CONFIG: Locale not specified explicitly. Set default locale to US. (RapidMiner.init())
2010-07-13 12:08:21 CONFIG: Initializing I18N (RapidMiner.splashMessage())
2010-07-13 12:08:21 CONFIG: Ensuring RapidMiner Home is set (RapidMiner.splashMessage())
Exception in thread "main" java.lang.NoClassDefFoundError: com/rapid_i/Launcher
       at com.rapidminer.tools.ParameterService.ensureRapidMinerHomeSet(ParameterService.java:63)
       at com.rapidminer.RapidMiner.init(RapidMiner.java:383)
       at FTLRG.trainNNRelations(FTLRG.java:678)
       at FTLRG.main(FTLRG.java:705)
Caused by: java.lang.ClassNotFoundException: com.rapid_i.Launcher
       at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
       at java.security.AccessController.doPrivileged(Native Method)
       at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
       at sun.misc.Launcher$ExtClassLoader.findClass(Launcher.java:229)
       at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
       at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
       at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
Can anybody please give me a clue about what's wrong here? Do I miss including any library here? I've imported the rapidminer.jar. But this thing 'com/rapid_i/Launcher' is said to be missing. I've tried to include launcher.jar too, but it didn't have any effect.

Thanks in advance,


  • Options
    landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Hi Wendy,
    you will need the rapidminer.jar as well as the launcher.jar in class path for integrating rapid miner. Probably you will have to include many of the other libs, but this depends on what you are going to do.

  • Options
    wendywendy Member Posts: 7 Contributor II
    Thanks Sebastian.

    I have tried including all other libraries and the problem still persists. I can't even initialize the RM. What's weird is, that I can do this with the older RM4.6.

    Anyways, thanks for the suggestions. I'd try again later.

Sign In or Register to comment.