🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

"RapidMiner and R installation issue"

ccrabbccrabb Member Posts: 6 Contributor II
edited May 2019 in Help
Another post on getting R to work.  After installing R, RapidMiner keeps coming up and asking to be restarted after it has notified that it has found the R libraries.  This is an infinite loop.  You'll have to understand that I have been through the installation instructions, re-installed RapidMiner and so forth, the typical things one does with open source to get it to work.  This is on a Windows platform.  The PATH, R_HOME and JAVA_HOME are set as per the installation instructions in RapidMiner..

Has anyone confronted this problem, or are few using R?
Tagged:

Answers

  • AjAj Member Posts: 23  Maven
    I had similar problems earlier. Please read the following posts and try the suggestions to check whether R gets installed correctly

    http://rapid-i.com/rapidforum/index.php?topic=3603.0;wap2

    http://rpy.sourceforge.net/rpy_faq.html

    Thanks,
    Aj
  • ccrabbccrabb Member Posts: 6 Contributor II
    Excellent.  It is as always getting the path correct.  There is a little ambiguity here.
    Also, the bin pointer in R 2.12 is qualified by the architecture, e.g. i386:  %R_HOME%\bin\i386
    Much thanks,
    /c
  • AjAj Member Posts: 23  Maven

    Two points are key to make it work, at least what it turned out to me (It is actually R problem than Rapidminer)

    1) Compiling R such that lib.so is present - instruction are in the URL http://rpy.sourceforge.net/rpy_faq.html

    2) Proper path for that dynamic linking library,
    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH\
              :R_HOME/bin
  • LaszloLaszlo Member Posts: 6 Contributor II
    Two points are key to make it work, at least what it turned out to me (It is actually R problem than Rapidminer)

    1) Compiling R such that lib.so is present - instruction are in the URL http://rpy.sourceforge.net/rpy_faq.html

    2) Proper path for that dynamic linking library,
    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH\
              :R_HOME/bin
    I'm having trouble as well.  Using Windows XP and R 2.13.1.  I've checked and re-checked all the paths.  I'm not familair with "makefile" or "nmake,"  so it's hard for me to follow the above instructions.  Any (simple) advice would be appreciated!
  • AjAj Member Posts: 23  Maven
    I have not tried installing R in Windows. Could you please check the following points

    1) While navigating manually in your R installation directory, are you able to locate lib.so equivalent in Windows, R.dll . I had to use "--enable-R-shlib" in Linux for installation of lib.so . Without that option, lib.so was not installed.

    2) The LD_LIBRARY_PATH path mentioned is just a suggestion of where lib.so will be. But, it will not be exactly there even in Linux. You have to cross check lib.so ( R.dll in Windows) exact path before setting it as environment variable

    3) If you have done both of the above points right, one thing I would suggest, which I had done in my case, is to uninstall R completely and possibly even RapidMiner. First install R and set the paths correctly and then install RapidMiner. I don't know how much difference this step will make, but I had done it in my case.

    I do not know whether the answer is simple, but I have not installed R in Windows OS to give more specific suggestions.

    Thanks,
    Ajay
  • LaszloLaszlo Member Posts: 6 Contributor II

    After uninstall/'reinstall  I got rid of the error msg. but RapidMiner does not have the R extension available.  Under 'manage extensions' the box is checked, but there is no "R" on the toolbar.
    Also, I now went into R and tried to load the rJava package, but it is unable to find the jvm.dll.

    I have JAVA_HOME set to C:\Program Files\Java\jre1.60_07\bin
    and
              R_HOME set to C:\Program Files\R\R-2.13.1\bin\i386

    I confirmed that the R.dll was located there.

    I'm afraid that I've really messed things up now  ???

    Any thoughts?
  • AjAj Member Posts: 23  Maven
    Hi,

    There are three variables that need to be set for R to work with RapidMiner. In my Linux system I issued the following three commands and got the following results

    echo $R_HOME
    /usr/local/lib/R
    This should be corresponding to the directory where R.exe or something like that exists

    echo $LD_LIBRARY_PATH
    /usr/local/lib/R/lib
    This is corresponding to the directory where R.dll exists

    echo $JAVA_HOME
    /etc/alternatives/java_sdk

    After installing R, did you install components by going to
    Help -> Update RapidMiner
    and choosing to install R Extension ?
    If you have not installed this extension, not setting the environment variables correctly will not give any error message. In this scenario, the problem is not solved.

    If you have done all of the above steps correctly and R icon is not showing up, then in RapidMiner did you check in
    View -> Show View
    to see whether there are any R icons?

    I am also unable to run
    rJava
    in terminal. I noticed that you used the word "load" and not run "rJava" from terminal. But, just to make sure, did you execute the load command for some module like
    load("rpart")
    before executing
    rpart ?

    Thanks,
    Ajay
  • AjAj Member Posts: 23  Maven
    Sorry, I wrote
    load("rpart")
    the correct loading command is
    library("rpart")

    Regards,
    Ajay
Sign In or Register to comment.