Rapidminer Web Server Web Page Not Found Error

OctopusOctopus Member Posts: 7 Learner I
edited December 2021 in Help
Dear RapidMiner Community,

I was able to successfully install Rapidminer Server on my computer and was also able to successfully run the service. During the installation process, I have also tested my connected to the SQL Server and it was successful. However, whenever I try to use my Google Chrome and Microsoft Edge browser to run the web page (according to the installation documentation, this should turn into a login page), I always get the error: ERROR 404 Web Page Not Found. Does anyone know how this can be solved?

When I start the server using net start RMSSVC or by manually starting it in services.msc, the server runs successfully but the web page is not found. However, when I run the server sing the standalone.bat file, the server was not able to run.

I attached a log file from the standalone.bat

Any help will be greatly appreciated!


  • OctopusOctopus Member Posts: 7 Learner I
    edited December 2021
    Please ignore this log file as it is the same as the one above. 
  • aschaferdiekaschaferdiek Employee, Member Posts: 76 RM Engineering
    Hi @Octopus . In order to see what might be the cause, could you please provide the full server logs so we are able to look into that? Thanks.
    Is the web page also not visible when you don't use Microsoft Windows services to start and just the plain .bat file inside the bin/ directory?
  • OctopusOctopus Member Posts: 7 Learner I
    Hi @aschaferdiek, When I run it using Microsoft windows services, the server starts up but webpage is not found (There is one time that I was able to run the webpage also, but the next day, without touching anything, it failed again to load  the webpage.) When starting it up using standalone.bat file, the server did not run.

    Attached is the standalone.log file. Thank you!
  • OctopusOctopus Member Posts: 7 Learner I
    @aschaferdiek, attached here is the server.log file
  • aschaferdiekaschaferdiek Employee, Member Posts: 76 RM Engineering
    @Octopus Thanks for your input. It seems that the installation might be corrupted and thus a required Java library cannot be loaded.
    Caused by: org.jboss.modules.xml.XmlPullParserException: Failed to add resource root 'cxf-rt-transports-local-2.7.13.redhat-4.jar' at path 'cxf-rt-transports-local-2.7.13.redhat-4.jar' (position: END_TAG seen ...resource-root path="cxf-rt-transports-local-2.7.13.redhat-4.jar"/>... @44:76) caused by: java.util.zip.ZipException: zip file is empty
    My recommendation, to rule out any other error, is to reinstall AI Hub. For this, please download the installer zip file again, reinstall AI Hub into another folder and take another RapidMiner AI Hub Home directory during installation.

Sign In or Register to comment.