🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

"Loop of Death"

cidielcidiel Member Posts: 6 Contributor II
edited May 2019 in Help
How about this one, interesting.. I updated my rapid version and R plug-in and it redid the installation process and found the libraries and all seemingly OK. As I click the exit restart button, it never restarts.. fine no problem i restart it myself only to wind up back in the R plugin installation process again... Can't get out!!

Answers

  • BehaviorAnalystBehaviorAnalyst Member Posts: 1 Contributor I
    I get a bit further before the loop starts.  When I click NEXT, I get

    Found Library in C:\Program Files\R\R-2.12.2.0\library\r.Java\jri\JRIEngine.jar  This is a good thing.  I can click OK to get to the EXIT now, I will restart RapidMIner.  That's when the loop starts.  Interestingly, If I click the upper right hand corner X to exit the dialogue box, I do go to RapidMiner, but then get this error:

    Could not load native library The local binary library 'C:\Program Files\R\R-2.12.2.0\library\r.Java\jri\JRIEngine.jar' could not be loaded
    Reason: C:\Program Files\R\R-2.12.2.0\library\r.Java\jri\JRIEngine.jar %1 is not a valid WIN32 application.

    This is odd, as I only downloaded the WIN32 files and not any WIN 64 files.

    I can still run the application, but not the R operator.

    I uninstalled all, re-downloaded all files to make sure that all were WIN 32 and got the same results.

  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531   Unicorn
    Hi,
    well, I will add a Button do deactivate the extension if you can't get it to work. Until then, please press the X button of the dialog and deactivate the Extension in the Help / Manage Extensions Menu.

    @BehaviorAnalyst.
    Please install R 2.12.0, since I don't have tried it with 2.12.2. Then please check if the jri.dll in the C:\Program Files\R\R-2.12.2.0\library\rJava\jri\ directory is indeed a copy of the C:\Program Files\R\R-2.12.2.0\library\r.Java\jri\i386\jri.dll

    Greetings,
      Sebastian
  • HieroBoschHieroBosch Member Posts: 1 Contributor I
    I have the exact same problem cidiel has.. I just installes R and was looking forward to using it.. so I install R and everything seems OK, until I get into the same loop of death.. and when instead of clicking the "exit restart" button I press the x button RapidMiner opens and tells me he could not find the respective jri.dll.. So how come he found it during the installation, or at least made me believe..

    best,
    HieroBosch
  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531   Unicorn
    Hi,
    we will make another update as soon as possible cutting this loop and we are heading for including the complete R into the Extension, so that any inconvenient configuration will be avoided.

    Greetings,
    Sebastian
  • AjAj Member Posts: 23  Maven
    Hello,

    I had also encountered this problem and I have found the solution. I have posted my original question and the solution at the following post

    http://rapid-i.com/rapidforum/index.php/topic,3603.0.html

    In essence, using something like

    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH\
              :R_HOME/bin

    in  .bashrc worked out for me.
    If it does not work, i.e if lib.so is missing, try follow the instructions at the URL
    http://rpy.sourceforge.net/rpy_faq.html

    It looks like it is more of an R problem than that of rapidminer.

    Thanks
    Ajay
  • IngoRMIngoRM Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Community Manager, RMResearcher, Member, University Professor Posts: 1,751  RM Founder
    Hi Ajay,

    those are great infos - thanks for finding out!

    Cheers,
    Ingo
Sign In or Register to comment.