🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

Issue connecting to Oracle database

tmyerstmyers Member Posts: 21 Contributor I
edited November 2018 in Help

Hello everyone. I'm having a problem connecting to an Oracle database. I am using RapidMiner 5.3 which allows for Oracle connections. I have added the jdbc_properties.xml file to the user/.RapidMiner5 folder. This jdbc_properties.xml contains the following:


<?xml version="1.0" encoding="UTF-8"?>
<drivers>
<driver urlprefix="jdbc:mysql://" name="MySQL" drivers="com.mysql.jdbc.Driver" driver_jar="" defaultport="3306" dbnameseparator="/"/>
<driver urlprefix="jdbc:postgresql://" name="PostgreSQL" drivers="org.postgresql.Driver" driver_jar="" defaultport="5432" dbnameseparator="/"/>
<driver urlprefix="jdbc:jtds:sybase://" name="Sybase" drivers="net.sourceforge.jtds.jdbc.Driver" driver_jar="" defaultport="7100" dbnameseparator="/"/>
<driver urlprefix="jdbc:hsqldb://" name="HSQLDB" drivers="org.hsqldb.jdbcDriver" driver_jar="" defaultport="9001" dbnameseparator="/"/>
<driver urlprefix="jdbc:odbc:" name="ODBC Bridge (e.g. Access)" drivers="" driver_jar="" defaultport="" dbnameseparator=""/>
<driver urlprefix="jdbc:jtds:sqlserver://" name="Microsoft SQL Server (JTDS)" drivers="net.sourceforge.jtds.jdbc.Driver" driver_jar="" defaultport="1433" dbnameseparator="/"/>
<driver urlprefix="jdbc:ingres://" name="Ingres" drivers="ca.ingres.jdbc.IngresDriver,com.ingres.jdbc.IngresDriver" driver_jar="" defaultport="II7" dbnameseparator="/"/>
<driver urlprefix="jdbc:oracle:thin:@ name=Oracle" drivers="oracle.jdbc.driver.OracleDriver" driver_jar="C:\Oracle\instantclient_12_2\ojdbc8.jar" defaultport="1521" dbnameseparator="/"/>
</drivers>

 

I have also tried the driver_jar link to C:\Program Files (x86)\Rapid-I\RapidMiner5\lib\jdbc\ojdbc8.jar where I have placed a 2nd copy of the file.

 

When I try to restart the software, the launch freezes when it gets to "Loading JDBC Drivers". I have to remove the .xml file to then get the program to start.

 

Does anyone have an idea on why this happens, or how I can revise the xml file to properly call the driver?

 

Thanks in advance for any guidance,

 

Tim

Tagged:

Answers

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,760   Unicorn

    Hi,

     

    V5.3 is long time ago but I do seem to remember some sort of Oracle issue between v5.2 and v5.3.  Have you tried using this on the current version 7.5? Does it work there?

  • tmyerstmyers Member Posts: 21 Contributor I

    Hey Thomas. I am using community version 6.5 due to the record limitation in the newer versions. While this prevents me from using the built-in driver manager under Tools, I am able in 6.5 to load the jdbc_properties.xml to the user/.RapidMiner folder and successfully test the Oracle connection from the Read Database operator. (If I run the process, it then of course throws the error that Community version doesn't support Oracle).

     

    Regards,

     

    Tim

     

     

     

     

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,760   Unicorn

    Yeah 6.5 has the unlimited rows but crippled the commercial databases. Couldn't you use v7.5, make the connection to Oracle and just use 10,000 rows? I mean the other option is just buy a license of RapidMiner and help pay for my salary? :smileyhappy:

  • tmyerstmyers Member Posts: 21 Contributor I

    Hey Tom, while I'm all for supporting RM staff's salaries :smileytongue:, the current price points of the paid versions are not feasible to our company at the moment. I would try the current free versions, but somtimes I deal with datasets with millions of rows, so the row limit prevents that option.

     

    Do you recall what the differences were between 5.2 and 5.3 that caused the Oracle issue? Was there ever a fix? I've seen reference to an old Wiki for this version but the links are always bad.

     

    Thanks,

     

    Tim

     

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,760   Unicorn

    I'm not sure if there was a fix or not, have you checked out the original (Old) forum here: http://community.rapidminer.com/t5/Original-Rapid-I-Forum/bd-p/UCASE. 

     

     

  • tmyerstmyers Member Posts: 21 Contributor I

    Just looked, not much there when I search for Oracle. The one forum post I found that I tried following is here:

     

    http://community.rapidminer.com/t5/RapidMiner-Studio-Forum/Oracle-JDBC/td-p/14871

     

  • tmyerstmyers Member Posts: 21 Contributor I

    Also tried what was suggested in this post:

     

    http://community.rapidminer.com/t5/RapidMiner-Studio-Forum/Database-Connection-In-RM-5-0-using-SQL/td-p/6746

     

    It's as if simply by placing the xml file in the user/.RapidmIner5 folder it causes it to freeze up and not fully launch.

     

  • Edin_KlapicEdin_Klapic Moderator, Employee, RMResearcher, Member Posts: 295  RM Data Scientist

    Hi tmyers,

     

    Perhaps the issue is related to the driver and/or the oracle version?

    If I remember correctly I used ojdbc6 with oracle11.

     

    Best,

    Edin

  • tmyerstmyers Member Posts: 21 Contributor I

    Thanks Edin. I'm using ojdbc8.jar to connect to Oracle 12.2. When I test the connection I get the following error:

     

    Io exception: Invalid connection string format, a valid format is: "host:port:sid"

     

    This is strange, beacuse I don't receive this error connecting with other software using the service_name rather than SID. The URL that normally works is this:


    jdbc:oracle:thin:[host]:1521/[service_name]


    Below are the driver details from the jdbc_properties.xml file in my user/.RapidMiner5 folder. Any other idea on what could be causing the error?

     

    <driver urlprefix="jdbc:oracle:thin:@ name=Oracle12.2" drivers="oracle.jdbc.driver.OracleDriver" driver_jar="C:\Program Files (x86)\Rapid-I\RapidMiner5\lib\jdbc\ojdbc8.jar" defaultport="1521" dbnameseparator="/"/>


    Thanks in advance for any suggestions/advice-

     

    Tim

     

Sign In or Register to comment.