🦉🦉   WOOT WOOT!   RAPIDMINER WISDOM 2020 EARLY BIRD REGISTRATION ENDS FRIDAY DEC 13!   REGISTER NOW!   🦉🦉

on Server - "Send test email" works; using Send Mail operator does not

jsmithjsmith Member Posts: 3 Contributor I
edited December 2018 in Product Feedback - Resolved

Using RM Server 8. When I send a test email in System Settings, it works fine. When I use the Send Mail operator in a process run on the server, it does not work.

 

I added com.rapidanalytics.mail.jndi_name = java:/Mail to the config files under job-agent (and job-agent sub folders) to see if that would work - even though it's redundant - but nothing. Also, if I run the process in RM Studio on same machine (with same settings that were used in RM Server setup), it works.

 

Log is attached.

 

Please advise. Thanks.

Tagged:
RayJhongIngoRM
2
2 votes

Fixed and Released · Last Updated

9.4.1 PROD-365

Comments

  • SGolbertSGolbert RapidMiner Certified Analyst, Member Posts: 341   Unicorn

    Hi,

     

    I've been able to reproduce your problem. I can confirm that this problem wasn't present in Server 7.6.

     

    We are working on a solution.

     

    Thank you for your post!

  • jwpfaujwpfau Employee, Member Posts: 22   RM Engineering

     

    As a workaround:

    • copy your local /home/username/.RapidMiner/cipher.key file into the RapidMiner Server/job-agent/config/container/.RapidMiner folder
    • copy the following lines from the /home/username/.RapidMiner/rapidminer-studio-settings.cfg to the RapidMiner Server/job-agent/config/container/container.properties file:
      • rapidminer.tools.mail.sender
      • rapidminer.tools.smtp.user
      • rapidminer.tools.smtp.passwd
      • rapidminer.tools.smtp.host
      • rapidminer.tools.smtp.port
      • rapidminer.tools.smtp.security
      • rapidminer.tools.smtp.authentication
  • sgenzersgenzer 12Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,653  Community Manager

    moving to Product Feedback.


    Scott

     

     

  • RayJhongRayJhong RapidMiner Certified Analyst, Member Posts: 11 Contributor II

    I encountering the same issue, seems like RM8 server can't apply the smtp host & port in /standalone/configuration/standalone.xml. So using the default smtp host & port as localhost & 25 alternatively.

    <outbound-socket-binding name="mail-smtp">
    <remote-destination host="smtp.office365.com" port="587"/>
    </outbound-socket-binding>

     Screen Shot 2018-02-06 at 11.36.17 AM.png

    It's a frequent used operator for us in production env, plz fix it.

     

    Sincerely,

    Ray Jhong

  • sgenzersgenzer 12Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,653  Community Manager

    reported to dev team - will update when addressed.

     

    SG

     

     

  • jose_mejiasjose_mejias Member Posts: 1 Contributor I

    any updates.  Having the same issue

     

  • sgenzersgenzer 12Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,653  Community Manager

    hello - status is that it's still in the JIRA queue with the dev team. "Upvoting" here on this forum will definitely send signals about prioritization.


    Scott

     

  • AndrewB1AndrewB1 Member Posts: 3 Contributor I

    The "work around" works well for us.   If you take the settings that used to go into standalone.conf and place them into each job agents container.properties   as 

    rapidminer.tools.smtp.host = somehost.com

    rapidminer.tools.smtp.port = 25

    The send mail should work just fine from server and will not use localhost.

Sign In or Register to comment.