"Startup problem with R"

SeanSean Member Posts: 3 Contributor I
edited May 2019 in Help
Hi There,

I'm probably doing something silly here but when I try to install the R extension and restart RapidMiner, RapidMiner keeps restarting itself. The splash screen keeps cycling and the main window never appears.

I have the 64 bit version of R and am invoking the 64 bit version of RM.

I have downloaded and reinstalled the latest 64 bit JRE and have the latest releases of R and RM. All other plugins seem to be working. I am also pointing to the 64 bit jri in rJava.

Any suggestions welcome.

Regards,
S


I should also mention that the OS is Win7 x64. Any help appreciated as I have looked through the documentation again and still cannot see where I am going wrong.
Tagged:

Answers

  • RMRRRMRR Member Posts: 12 Contributor II
    I think I've narrowed down the problem, at least in my case and hopefully in everyone else's.  Dependency walker says that the jril.dll file can't find:

    JVM.DLL
    IESHIMS.DLL

    I obviously have both of those:

    JVM.DLL is here: C:\Program Files\Rapid-I\RapidMiner5\jre\bin\server, here: C:\Program Files\Rapid-I\RapidMiner5\jre\bin, and here: C:\Program Files\Rapid-I\RapidMiner5\jre\bin\server

    IESHIMS.DLL is in various places, almost half of which are in I.E. directories.


    My environment settings are:

    JAVA_HOME
    C:\Program Files\Rapid-I\RapidMiner5\jre;C:\Program Files\R\R-2.12.1\bin\x64

    R_HOME:
    C:\Program Files\R\R-2.12.1\bin\x64

    PATH:
    C:\Program Files\R\R-2.12.1\bin\x64; C:\Program Files\Rapid-I\RapidMiner5\jre

    Any suggestions on what to do now?

    Thanks.



  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Hi,
    your JAVA_HOME needs to be set to a SINGLE location. Use the JRE that is used for RapidMiner or at least having the same architecture (x32), (x64). JAVA_HOME needs to point to the bin directory of your JRE installation!

    R_HOME needs to be set to the R directory and NOT subdirectorys.

    In the PATH you will need the R\bin\i386 or R\bin\x64 directory and the bin directory of the used JRE.

    Here are my settings as an example:

    PATH=C:\Program Files\R\R-2.12.0\bin\i386;C:\Program Files (x86)\Java\jdk1.6.0_22\bin
    JAVA_HOME=C:\Program Files (x86)\Java\jdk1.6.0_22\bin
    R_HOME=C:\Program Files\R\R-2.12.0


    Greetings,
      Sebastian
  • RMRRRMRR Member Posts: 12 Contributor II
    Here are the current settings. Still no luck

    JAVA_HOME: C:\Program Files\Java\jre6

    Path: C:\Program Files\R\R-2.12.1\bin\x64;C:\Program Files\Java\jre6

    R_HOME: C:\Program Files\R\R-2.12.1

    Running Windows 7 64bit.

    Rapidminer still cannot find jri.dll's dependent files...
  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Hi,
    well I'm sort of irritated. This should work. My only idea is that might be the user rights of the R-Install directory prevent RapidMiner from accessing the libraries? Did you try on the command line if the r.dll is in path?

    Greetings,
      Sebastian
  • edegraafedegraaf Member Posts: 2 Contributor I
    I had this same problem, specifically while starting rapidminer in a console
    First of all JAVA_HOME should not be the bin directory:

    JAVA_HOME=C:\Program Files (x86)\Java\jdk1.6.0_22\bin

    should be

    JAVA_HOME=C:\Program Files (x86)\Java\jdk1.6.0_22

    My problem was that I had:

    JAVA_HOME=C:\Program Files (x86)\Java\jdk1.6.0_22\

    This doesn't work for some reason

    Also, I had specific problems with the JRE installed with rapidminer and it was prefering this local jre, so I commented out this part in 'rapidminer.bat' in the directory 'scripts'
    such that it will always choose the 'global jre'

    Greetings,



  • RMRRRMRR Member Posts: 12 Contributor II
    Hi Sebastian,

    First of all, thank you for following up.  There is lots I'd like to with R for time series forecasting and am hopeful, with your help, I can get this working.

    I'm not sure what you mean by seeing r.dll path through the command line (dos? for windows).  What exactly am I checking?  Currently, r.dll is in the following directory:

    C:\Program Files\R\R-2.12.1\bin\x64

    Thnx.

    Rob
  • keithkeith Member Posts: 157 Maven
    Not sure if this is helpful, but I eventually got R for RM running under XP 64 bit, by going to Tools->Preferences->R and changing rapidminer.r.native.lib to:

    C:\Program Files\R\R-2.12.1\library\rJava\jri\x64\jri.dll

    This was not the location that was autodetected, so I had to manually set the directory and restart RM, at which point it worked.

    My environment variables are

    R_HOME=  C:\Program Files\R\R-2.12.1
    R_ARCH = "x64"
    PATH contains C:\Program Files\R\R-2.12.1\bin\x64
  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Hi Rob,
    please check if you have this directory inside your PATH. If you don't know what the PATH is, please see http://en.wikipedia.org/wiki/PATH_(variable).

    Please consider becoming enterprise customer for getting real time support.

    Greetings,
    Sebastian
  • KadirKadir Member Posts: 1 Contributor I
    Thanks Keith!  Your post clued me into solving my own problem.

    I was also having trouble with Rapid Miner saying it successfully detected the jri.dll file and then asking to restart Rapidminer.  To just trapped me in an unending loop with no real description of where the problem was occurring.

    I am using Rapidminer 5.2 and R 2.14.1 both x64 versions.

    I discovered that my ultimate problem was that I was pointing to the wrong rapidminer.r.native.lib file. Originally I was pointing toC:\Users\Kadir\Documents\R\win-library\2.14\rJava\jri\jri.dll.  This is a 32 bit architecture file and was causing all of my problems.  It should have pointed to C:\Users\Kadir\Documents\R\win-library\2.14\rJava\jri\x64\jri.dll

    The path, environmental variables and the rapidminer.r.native.lib file all need to be pointed at either x64 or x86 bit versions.

    The path and environmental variables can be set from outside of rapidminer, but to fix the r.native.lib file I had to disable the extension and then go to:  Tools -> Preferences -> R and change the location.  Then I had to re-enable the R extension and everything worked well.

    Hope this helps at least a few more people out. 
  • sbrown2594sbrown2594 Member Posts: 1 Contributor I
    Thanks everyone!  I had the same problem, and following this thread helped.  Here's a summary for the next person who runs into it.

    First I set my path variables like Sebastian suggested:
    R_HOME needs to be set to the R directory and NOT subdirectorys.

    In the PATH you will need the R\bin\i386 or R\bin\x64 directory and the bin directory of the used JRE.

    Here are my settings as an example:

    PATH=C:\Program Files\R\R-2.12.0\bin\i386;C:\Program Files (x86)\Java\jdk1.6.0_22\bin
    JAVA_HOME=C:\Program Files (x86)\Java\jdk1.6.0_22\bin
    R_HOME=C:\Program Files\R\R-2.12.0
    and then followed Keith's and Kadir's advice to change to the correct .dll file for x64 processors:
    I discovered that my ultimate problem was that I was pointing to the wrong rapidminer.r.native.lib file. Originally I was pointing toC:\Users\Kadir\Documents\R\win-library\2.14\rJava\jri\jri.dll.  This is a 32 bit architecture file and was causing all of my problems.  It should have pointed to C:\Users\Kadir\Documents\R\win-library\2.14\rJava\jri\x64\jri.dll

    The path, environmental variables and the rapidminer.r.native.lib file all need to be pointed at either x64 or x86 bit versions.

    The path and environmental variables can be set from outside of rapidminer, but to fix the r.native.lib file I had to disable the extension and then go to:  Tools -> Preferences -> R and change the location.  Then I had to re-enable the R extension and everything worked well.
    Everything should work just fine!
  • habibalexhabibalex Member Posts: 7 Contributor II
    what a PITA! worst directions ever.  My rapidMiner kept failing to load after the GUI.  The main problem was the unclear R_HOME directory.  You just need the installation directory, not any of the \bin\x64 ect...
    This is what worked for me after many failed combinations.  Also, use the java that is in the rapidMiner directory, you don't need to download java x64 if its not currently installed.

    I am using win7 x64, w/ x64 R, RapidMiner and Java (that came with rapidMiner x64)

    JAVA_HOME = C:\Program Files\Rapid-I\RapidMiner5\jre\bin
    Path = [other stuff];C:\Program Files\Rapid-I\RapidMiner5\jre\bin;C:\Program Files\R\R-2.15.0\bin\x64
    R_HOME = C:\Program Files\R\R-2.15.0

    rapidminer.r.native.lib = C:\Users\rajiv\Documents\R\win-library\2.15\rJava\jri\x64\jri.dll
  • krackonkrackon Member Posts: 1 Contributor I
    To get it to work with win7 64 I had to rename the jri.dll located at C:\Program Files\R\R-2.14.1\library\rJava\jri so stop rapid miner from automatically selecting it.  Then rapid miner would prompt for the location of the of jri.dll.  choose C:\Program Files\R\R-2.14.1\library\rJava\jri\x64\jri.dll.

    going to Tools->Preferences->R and changing rapidminer.r.native.lib to:

    C:\Program Files\R\R-2.14.1\library\rJava\jri\x64\jri.dll

    wouldn't work for me.
Sign In or Register to comment.