"[SOLVED] R Plugin very slow 'Initializing Plugin GUI'"

pofigsterpofigster Member Posts: 3 Contributor I
edited June 2019 in Help
Howdy everybody.  I'm very new to RapidMiner and I'm loving a lot of what I'm seeing.  When I read I could integrate R I was chomping at the bit to try it out.

Initially, I had R 3.0.2 installed, added the R Plugin to RapidMiner and tried to follow the instructions on first startup.  It took me a while to figure out how to add environment variables, but I now have an %R_HOME%, %JAVA_HOME% and added %R_HOME%\bin\x64 to the PATH variable (separating it from the previous value with a ;).  When I restarted RapidMiner it loads to a point until it says 'Initializing Plugin GUI' and just sits there.  Occasionally (and seemingly randomly) the window to select the RCRAN Mirror pops up (and I pick the OH server).  I assumed it had crashed trying to do something, so I uninstalled the extension and reinstalled it to see what would happen.  Same thing.

Next I thought it might be there were changes in R 3.x that broke the extension (they broke the link to JMP 10).  I uninstalled R 3.0.2 and installed R 2.15.3 - same thing.  Then I started writing this post to see why it was crashing and after several minutes, it finally loaded.  I was excited and added an R script node but messed up something so a simple operation was taking too long.  I closed RapidMiner and reopened it and it's just as slow the second time (so it wasn't just an initial setup thing).

Is there something I can do to speed up the launching of RapidMiner and still keep the R Plugin?  Have I done something wrong?

Thanks!
Tagged:

Answers

  • MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869 Unicorn
    Hi,

    which operating system are you using? How much memory is available for RapidMiner?

    Did you install rJava from the R console?

    Usually the RCRAN mirror dialog should not pop up during the startup of RapidMiner.

    Best regards,
    Marius
  • pofigsterpofigster Member Posts: 3 Contributor I
    Marius,

    I'm having this problem on 2 computers and not having this problem on 1.

    The two computers I'm having this issue on are Windows 7 Enterprise 64-bit.  The one computer I'm not having issues with is Windows 8 Professional 64-bit.  On all of these machines I'm a standard user, not an administrator.

    My laptop (Win 7 Ent) has 4 Gb of RAM, my Virtual Machine (Win 7 Ent) has 8 Gb and my Home Desktop (Win 8 Pro) has 8 Gb

    In all three cases, I launched the R GUI (x64 version) and ran install.packages("rJava").  They all installed to the C:\Users\user\Documents\... library.

    My laptop and home desktop both have Java JRE 7, my Virtual Machine has JRE 6.

    On both of the Win 7 machines the behavior is constant - it takes a long time to load (several minutes) and prompts for the CRAN Mirror.  On my home computer, this doesn't happen, it opens reasonably quickly and does not prompt for the CRAN Mirror.

    The laptop and VM are both behind a proxy, so R uses the internet2.dll and I've passed the proxy information to Rapid Miner (obviously as I've installed the add-in).  My home desktop is not behind a proxy and so R uses the standard internet access methods.

    Thanks!
  • eliospaceeliospace Member Posts: 1 Contributor I
    Hi all, I have the same problem. Using RapiMiner 5.3 and R extension 5.3, R 3.0.1, java 7. (all 64bits on a windows7 64bits PC).Downloaded and installed rjava 0.9-5.zip from console. This way it does install the rjava in a user folder and not in the Program Files\R\plugin folder.

    the PC is a enterprise machine, thus behind a firewall.

    I found in blogs that the JAVA_HOME is not necessary when working on a 64bits machine.

    Nevertheless, both conditions (with and without JAVA_HOME as environment variable does not make any difference. I still get a long wait dring initialization and then it pops up the CRAN server list. takes ages just to initialize

    I wonder if some components have been updated and are version not compatible among them: RM - java7 - R - rjava.

    Let me add a pattern I also identified: the CRAN server popup windows happens to me also only on the Windows  7 Enterprise but not in the Windows Professional. I guess the internet connection does not matter because though the Enterpise machine is behind a proxy (and I configured the RM interface), on the other side the W7 Professional machine starts up quickly also being offline, thus I guess there is no need of CRAN server validation.


    Elio
  • midmid Member Posts: 4 Contributor I
    I am having the same problem as described in the previous posts. RapidMiner 5.3, R Extension, R 3.1.0, rJava, and Java are installed on a 64-bit system. The R Extension runs, BUT:

    1. During the startup of RapidMiner, the "Initializing Plugin GUI" phase takes around 15 minutes. After that time, a window for selecting a CRAN mirror pops up. Immediately after closing that window, RapidMiner starts.

    2. I created a process that contains nothing else than the "Generate Vector" example operator from the R Extension. Executing this process takes around 15 minutes. After that time, a window for selecting a CRAN mirror pops up. Immediately after closing that window, the result is displayed.

    Is there a solution for this problem?
  • MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869 Unicorn
    Hi,

    if you are on Windows and behind a proxy, you have to set an environment variable called HTTP_PROXY that points to your proxy, e.g.

    SET HTTP_PROXY=http://user:[email protected]:8080/

    or, without login:

    SET HTTP_PROXY=http://10.200.192.30:8080/

    With that variable the startup times should return to normal behavior.

    Best regards,
    Marius
  • midmid Member Posts: 4 Contributor I
    Hello Marius,

    thank you for your answer! You are right; after setting the environment variable, my R extension is working perfectly!
Sign In or Register to comment.