🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

Oracle Database Connection

archana_srarchana_sr Member Posts: 3 Contributor I
edited September 2019 in Help
Hi All,
I am trying to connect to a oracle database via "Read Database" operator. However it works if I run it locally in the studio, but on running it on the RM server I am getting the below error. I have tried two methods in define connection 1) Repository 2) url . Both doesn't seem to work on the RM server. I have tested the connection while in Repository option and I got "Test Connectivity" Success. It also runs in the RM studio, just not on the server. Any help is much appreciated.

Tghadially

Best Answer

Answers

  • rfuentealbarfuentealba Moderator, RapidMiner Certified Analyst, Member, University Professor Posts: 563   Unicorn
    Hello,

    There are many reasons on why would Oracle return the ORA-01017 error. Among the most common ones:
    • Are you trying to connect with a user without privileges from the machine that RapidMiner Server has?
    • Are you trying to connect to an Oracle 11 instance with the libraries from Oracle 9?
    • Are you sure that the connection is being made from "user", and not "user as sysdba" or something?
    I may be able to help, but for that I would require you to provide more information: what version of RM Server are you using? what version of Oracle are you using?

    All the best,

    Rod.
    sgenzerTghadially
  • archana_srarchana_sr Member Posts: 3 Contributor I
    The problem was as stated by @SGolbert the server did not have the same connectivity as my laptop.
Sign In or Register to comment.