RapidMiner 9.7 is Now Available

Lots of amazing new improvements including true version control! Learn more about what's new here.

CLICK HERE TO DOWNLOAD

Bagging optmization reduced performance

ravtalravtal Member Posts: 9 Contributor II
edited January 12 in Help
Hi,

I am running an attached dataset to measure the performance of the model. Decision tree gave me a good accuracy value, however, when I used a bagging operator to increase the performance of the model, the output reduced the performance accuracy.
Could anyone help me with what changes I need to make in the model so that accuracy is optimized?

Note: dataset has no attribute tables, uncheck "first row as names" and column operator value to "," while importing the dataset.

Regards,
RT
Jasmine_

Answers

  • mschmitzmschmitz Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 2,502  RM Data Scientist
    Hi @ravtal,
    this sounds like you overtrained your decision tree. Did you check for it?

    Best,
    Martin
    - Head of Data Science Services at RapidMiner -
    Dortmund, Germany
    ravtalJasmine_
  • ravtalravtal Member Posts: 9 Contributor II
    You mean I should reduce the depth?
    Jasmine_
  • varunm1varunm1 Moderator, Member Posts: 1,198   Unicorn
    Hello @ravtal

    As @mschmitz said, it might be due to overfitting. DId you try hyperparameter optimization using "optimize parameter grid operator"? You can search for the best hyperparameters for your algorithm and reduce overfitting.Β 
    Regards,
    Varun
    https://www.varunmandalapu.com/

    Be Safe. Follow precautions and Maintain Social Distancing

    ravtalJasmine_
  • ravtalravtal Member Posts: 9 Contributor II
    @varunm1 Ok, but do you think model design is good?
    Jasmine_
Sign In or Register to comment.